Bill Drafting Template
Word 2007

Montana Legislative Services Division
April 9, 2012

Introduction

The Bill Drafting template for Word 2007 is a tool to aid in drafting bills for the Montana Legislature.  The template provides boilerplate language and standard section format to eliminate some of the clerical problems associated with bill drafting, but a template is not a substitute for the substantive knowledge needed to correctly draft bills.  An understanding of the Bill Drafting Manual, published by the Legislative Services Division, is a requirement for bill drafting.

General Operation

Template:  A Word template is a collection of stored words, beginning formats, tool bar customization, and macros that when invoked at the start of a document controls the preparation of that document.

The template gets the MCA sections from the Legislative Services’ website, so an Internet connection is necessary to use it.

The template must be installed -- see Installation instructions at the end of this document.  Once installed, to draft a bill, start by clicking the Microsoft Office Button [image: ]then New, then pick Net Bill Drafting 2007.dotm  and OK. Do NOT start the bill drafting template in any other manner. When opened, click the Add-ins menu icon on your Word toolbar – the bill drafting menu is a new icon and has the scales of justice picture.  

The bill drafting template opens up with standard language and typeface, has headers and footers for a draft bill, puts the Strikethrough icon on the toolbar, and adds a Menu icon to the tool bar.  The template has a series of macros that are available only for documents opened with the template.

Macro Language: Use the macros whenever they can be used.  Take the time to learn them now, and they will save immense amounts of time later.  Time saving is only a part of the reason for the macros.  They ensure accuracy, and they are also an important part of the Legislative Services Division’s bill drafting system.  The macros provide certain coding to a bill draft that is used in producing the bill for introduction.

Don't change the material inserted by a macro and don’t edit a bill in the interests of esthetics or personal preferences -- required page ends, multiple tabs, and other codes inserted to make the draft look good must be removed by our office.  Nice formatting in drafting wastes time because the introduced bill will appear differently.  The "{}" codes in drafts are used to surround material that is deleted before a bill is printed for introduction.  If you delete the ending "}", all the material following until the next  ending "}" is deleted -- that's usually a section. 

Macro General Operations: To insert any standard bill drafting section, place the cursor where the section goes, click the Menu icon (with the scales of justice),  and  then choose the appropriate menu item.  For straight boilerplate (severability clause, immediate effective date, etc.), the macro will insert the section into the bill without further input.  For some sections, you must provide information.  The codification instruction macro pops up a form asking which sections are to be codified and in what Title, chapter, and part.  Other macros complete the basic section, but you must go into the section and provide missing language.  The effective date sections do not insert dates; you must go into the section and provide the dates.  Some macros amend the title while inserting a section. The repealer and date sections (immediate effective date, termination, etc.) amend the title as the macro runs.  The title changes are made at the end of the title, so insert these sections in the order that you want them to appear in the title.  Last but not least, the title macro sweeps through the bill and adds a clause to the title indicating which MCA sections have been amended in the bill.  Generally, the title is written last so you can accurately reflect the subject of the bill, and the title macro is the last of the title to be finished. 


Individual Macros 

Menu:  The basic menu, chosen from the Menu icon on the toolbar.  Have the cursor in place before using the macro because the chosen section appears at the cursor insertion point.  If you don’t want it where it appears, use Undo (blue left curving arrow) and try again.

Amend MCA:  The "all-in-one" macro.  Use to retrieve an MCA section.  Have the cursor at the left margin where you want the section.  It retrieves the section, with the necessary amendatory wording at the beginning, automatic paragraph number, section number tagged for the title macro, opening and closing quotes, and an internal reference report. The macro waits to accept a series of MCA sections if you wish. After the first section, it gives the last section number retrieved, which helps when entering a long series of sections.  Check each section in the internal reference report and use Word to put an "x" by each cite checked.  Don't mark a printout of the bill with a pen or pencil because the mark is lost at the bill’s next printing and doesn’t travel with the electronic version.
	Note:  If you get an error message with error number 4198, it means your copy of Word was not installed with the WordPerfect to Word format installed.  Contact your IT staff to install the converter.

New Section: At the cursor, inserts 
NEW SECTION.  Section 1. _ 
The cursor is within bold codes for writing the catch line.  Click off bold when starting the section text.  The section number is automatic and adjusts if sections are inserted before it.

Ballot Issue: At the cursor, inserts a standard section for putting a statewide issue on the general election ballot in November 2010.   You must complete the For and Against Ballot Language.

Saving Clause:
[bookmark: Severability_Clause]Severability Clause: At the cursor, inserts either a standard saving clause or severability clause.  No drafter intervention is required. There isn’t an Anonseverability clause@ macro.

[bookmark: Codification][image: ]Codification Instr: Creates a codification instruction at the point you put the cursor. Enter the section numbers from the bill that are appropriate.  Use a phrase like the examples, but don’t set them in quotes. The Title number is required -- enter chapter and part numbers if appropriate. 

[bookmark: Termination]Termination:  Inserts a termination section at the cursor and inserts the necessary phrase in the title.  It stops for you to fill in the termination date. Avoid use of Termination, Contingent Effective Date, and Contingency clauses because of the complexity of maintaining multiple versions of these types of sections.

[bookmark: Retro__Appl_ty]Retro. Appl'ty: Inserts the following and inserts the necessary phrase in the title:
NEW SECTION.  Section 1. {standard} Retroactive applicability.  [This act] applies retroactively, within the meaning of 1-2-109, to _

[bookmark: Effective_Date]Effective Date:
[bookmark: Effective_Dates]Effective Dates:  At the cursor, inserts effective date or dates section and allows you to fill in the applicable date or dates.  It inserts the necessary phrase in the title to show an effective date is within the bill.

[bookmark: Imm__Eff__Date]Imm. Eff. Date: At the cursor, inserts an immediate effective date section in the bill and inserts the necessary phrase in the title.

[bookmark: Repeal]Repealer:  Inserts a standard repealer clause at the cursor.  Automatically lists internal references.  Keep entering one section at a time in numerical order.  The form shows the last section you repealed. Takes the listing and puts it into the title.  Check each section in the internal reference report and use Word to put an "x" by each cite checked.  Don't mark a printout of the bill with a pen or pencil because the mark is lost at the bill’s next printing and doesn’t travel with the electronic version.

[bookmark: Title]MCA in Title (last): LAST drafting macro.  Lists sections amended in the bill into the title in the order in which they appear in the bill.  The sections must be in numerical order in the bill. Put the cursor where you want the listing to appear (the first character of the sections list is a semicolon).  If you want to run the macro a second time, just delete the MCA listing in the title created by the first macro and run it again.  If there is only one MCA section in the bill, you will have to correct the title language a bit.

[bookmark: installation]Installation (Windows XP O/S & Word 2007)

Step 1:  Remove old version of template.  If you currently have a copy of the bill drafting template on your computer, remove it: while in Word, click the Microsoft Office Button [image: ], select New>My Templates, then right click on the Net Bill Drafting template and choose Delete, confirm the deletion, then Cancel to leave the dialog box.

Step 2:  Copy Net Bill Drafting 2007.dotm to your computer.  In your Internet browser, copy the template Net-Bill-Drafting-07.dotm from the current Bill Drafting Page (http://leg.mt.gov/css/Bills/bill-drafting.asp). To do this, right-click on the “Internet version” hypertext link that is located near the bottom of  the page under the title Bill Drafting Macros and Templates/Microsoft Word. In the drop-down menu, choose Save Target As… and save it to following “trusted” directory (the location is trusted by Word 2007 for macro enabled templates).

C:\Documents and Settings\<your username>\Application Data\Microsoft\Templates

Do NOT open or run at this point.

Step 3:  Open template.  In Microsoft Word, open Net Bill-Drafting-07.dotm.
Click the Microsoft Office Button[image: ]. Click New. Under the Templates column on the left of the New Document window, click New from existing…”

Use the Look in: box by clicking the down-triangle; near the top of the list, browse to the directory where you saved the file in Step 2. above then in the listing, choose Net-Bill-Drafting-07.dotm and click on Create New (you may name the new file now or wait until you have finished drafting it) .  

If you see the following warning, the template is not in a trusted directory. 
[image: ]
You can still use it but you will have to click Options… and Enable this content.

When opened, click Add-ins menu icon on your Word toolbar – it is a new icon and has the scales of justice picture.  

[image: ]

[image: ]
Step 4: Draft bills:  Start a bill with the Microsoft Office Button[image: ], New, and then pick the template Net-Bill-Drafting-07– this is the template for bill drafting and then click OK.
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Installation (Windows XP O/S & Word 2010)

Step 1:  Remove old version of template.  If you currently have a copy of the bill drafting template on your computer, remove it: while in Word, select File>New>My Templates, then right click on the Net Bill Drafting template and choose Delete, confirm the deletion, then Cancel to leave the dialog box.

Step 2:  Copy Net Bill Drafting 2007.dotm to your computer.  In your Internet browser, copy the template Net-Bill-Drafting-07.dotm from the current Bill Drafting Website (http://leg.mt.gov/css/Bills/bill-drafting.asp). To do this, right-click on the “Internet version” hypertext link that is located near the bottom of  the page under the title Bill Drafting Macros and Templates/Microsoft Word. In the drop-down menu, choose Save Target As… and save it to following “trusted” directory (the location is trusted by Word 2007 for macro enabled templates).

C:\Documents and Settings\<your username>\Application Data\Microsoft\Templates

Do NOT open or run at this point.  Click Save to save it to this directory.

Step 3:  Open template.  In Microsoft Word, open Net Bill-Drafting-07.dotm.
In Word Click File>New. Under the Available Templates section click “New from existing…”

Use the Look in: box by clicking the down-triangle; near the top of the list, browse to the directory where you saved the file in Step 2. above then in the listing, choose Net-Bill-Drafting-07.dotm and click on Create New (you may name the new file now or wait until you have finished drafting it to name it) .  

If you see the following warning, the template is not in a trusted directory. 
[image: ]
You can still use it but you will have to click Options… and Enable this content.

When opened, click Add-ins menu icon on your Word toolbar – it is a new icon and has the scales of justice picture.  

[image: ]

[image: ]
Step 4: Draft bills:  Start a bill with the Microsoft Office Button[image: ], New, and then pick the template Net-Bill-Drafting-07– this is the template for bill drafting and then click OK.
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[bookmark: _GoBack]

Installation (Windows 7 O/S & Office 2010)

Step 1:  Remove old version of template.  If you currently have a copy of the bill drafting template on your computer, remove it using these steps: while in Word select File>New, then under Available Templates select My Templates.  If it exists, Right-click on the Net Bill Drafting template and choose Delete, then confirm your deletion.  Select Cancel to return to Word.

Step 2:  Copy Net Bill Drafting 2007.dotm to your computer.  In your Internet browser, copy the template Net-Bill-Drafting-07.dotm from the current Montana legislative session Internet page  (http://leg.mt.gov/css/sessions/62nd/default.asp). Select the Bill Drafting link toward the bottom of the page to open the Drafting Bills page (http://leg.mt.gov/css/Bills/bill-drafting.asp), then  Right-click on the “Internet version” (for Word 2007) hypertext link that is located toward the bottom of the page. In the drop-down menu, choose Save Target As and save it to the following “trusted” directory as a Microsoft Word Macro-Enabled Template type (the location is trusted by Word 2010 for macro enabled templates).

C:\Users\<<username>>\AppData\Roaming\Microsoft\Templates

If the AppData folder is not visible you will need to enable viewing hidden files by Right clicking the Start button, select Open Windows Explorer, press the Alt key to enable menu options, and select Tools from the menu options.
[image: ]

Select Folder Options and under the View tab select the “Show hidden files, folders, or drives” option and click OK.  Return to Step 2 to save the template.
[image: ]

Step 3:  Open template.  In Microsoft Word, open Net-Bill- Drafting-07.dotm .
Click File>New and then My Templates under Available Templates (Ensure that Document is selected under the Create New section!).

[image: ]


[image: ]


If you see the following warning, the template is not in a trusted directory. 
[image: ]
You can still use it but you will have to click Enable Editing… and Enable this content.



When opened, click the Add-ins menu icon on your Word menu bar. This will enable a new icon that has the Scales of Justice picture. 

[image: ]


Step 4: Draft bills:  Start drafting a bill by selecting the appropriate Add-In options available in the Scales of Justice menu and clicking OK.  (Note that an appropriate Amend MCA code must be entered before the MCA in Title (last) option can be used).

[image: ]
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Installation (Windows 7 O/S & Word 2007)

Step 1:  Remove old version of template.  If you currently have a copy of the bill drafting template on your computer, remove it: while in Word, click the Microsoft Office Button [image: ], select New>My Templates, then right click on the Net Bill Drafting template and choose Delete, confirm the delete, then Cancel to leave the dialog box.

Step 2:  Copy Net Bill Drafting 2007.dotm to your computer.  In your Internet browser, copy the template Net Bill-Drafting-07.dotm from the current Montana legislative session Internet page  (http://leg.mt.gov/css/sessions/62nd/default.asp). Select the Bill Drafting link toward the bottom of the page to open the Drafting Bills page (http://leg.mt.gov/css/Bills/bill-drafting.asp),  then Right-click on the “Internet version” (for Word 2007)  hypertext link that is located near the bottom of the page. In the drop-down menu, choose Save Target As and save it to one of the following “trusted” directories as a Microsoft Word Macro-Enabled Template type (the locations are trusted by Word 2007 for macro enabled templates).  Click Save and close the dialog box.

C:\Users\<<username>>\AppData\Roaming\Microsoft\Templates

If the AppData folder is not visible you will need to enable viewing hidden files by Right clicking the Start button, select Open Windows Explorer, press the Alt key to enable menu options, and select Tools from the menu options.
[image: ]

Select Folder Options and under the View tab select the “Show hidden files, folders, or drives” option and click OK.  Return to Step 2 to save the template.
[image: ]

Step 3:  Open the template.  In Microsoft Word, open the Net-Bill-Drafting-07.dotm template to create a new document.
A. Click the Microsoft Office Button [image: ]. Click New. Under the Templates column on the left of the New Document window, click New from existing…”

B. Use the Look in: box by clicking the down-triangle; near the top of the list, browse to the directory where you saved the file in Step 2. above then in the listing, choose Net-Bill-Drafting-07.dotm and click on Create New.  

If you see the following warning, the template is not in a trusted directory. 
[image: ]
You can still use it but you will have to click Options… and Enable this content.

When opened, click the Add-ins menu icon on your Word menu bar. This will enable a new icon that has the Scales of Justice picture. 

[image: ]

Step 4: Draft bills:  Start drafting a bill by selecting the appropriate Add-In options available in the Scales of Justice menu and clicking OK.  (Note that an appropriate Amend MCA code must be entered before the MCA in Title (last) option can be used).
[image: ]
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Installation

Step 1: Remove old version of template. If you currently have a copy of the bill
drafting template on your computer, remove it: while in Word sclect File=New, then
under Available Templates select New From Existing and navigate to
C:\Users\<<username>>\AppData\Roaming\Microsoft Templates then right click on
the Net Bill Drafting template and choose Remove Template, then Confirm the deletion

Ifthe AppData folder is not visible youwill need to enable viewing hidden files by Right
clicking the Start button, select Open Windows Explorer, and press the Alt key to enable
menu options.

Step 2: Copy Net Bill Drafting 2007.dotm to your computer. In your Intemet
browser, copy the template Net Bill Drafting 2007.dotm from the current
Montana legislative session Internet page

(http:/leg mt. gov/css/sessions/62nd default.asp). To do this, right-click on the “Inicrmet
version” hypertext link thatis located about half-way down the page. In the drop-down
menu, choose Save Target As and save it to the following “trusted” directory. The
location is trusted by Word 2010 for macro enabled templates

C:\Users\<<username>>\AppData\Roaming\Microsoft Templates

caps Files (x86) Microsoft Office Templ

Step 3: Open template. In Microsoft Word, openNet Bill Drafting 2007.dotm .
Click File>New and then New From Existing under Available Templates. Browse to the
directory where you savedthe file in Step 1 above thenin the listing, choose Net Bill
Drafting 2007.dotn and click on Create New.

If you see the following waming, the templateis notin a trusted directory.
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